Canada Inbound Call completion issue

Incident Report for Vonage Enterprise System

Resolved

We have resolved the inbound calling issue that some customers experienced with receiving calls. If you are still having an issue, please contact our support teams at 1-888-616-6414.
Posted Apr 13, 2022 - 16:29 UTC

Monitoring

We are currently observing expected call behavior and are continuing to monitor for prolonged stability.
Posted Apr 13, 2022 - 15:32 UTC

Identified

Inbound calling issue has been resolved for some Vonage Business customers by our carrier vendor.
Posted Apr 13, 2022 - 15:30 UTC

Investigating

Some Vonage Business customers may be experiencing issues receiving calls. Our carrier is working to quickly resolve the issue.
Posted Apr 13, 2022 - 14:55 UTC
This incident affected: Voice Services (Inbound Calls).